Help us improve Agile UI consistency


#1

Currently some methods which return JavaScript action are prefixed with “js”:

  • Table::jsRow
  • TableColumn\Checkbox::jsChecked
  • Form::jsField()
  • Loader::jsLoad()

While other methods don’t use prefix:

  • Form::error() and Form::success()
  • Modal::show() and hide()

Which approach should we use and why?

Vote here: https://github.com/atk4/ui/issues/253