Extra popup messages with CRUD actions



First off, my great thanks to the Agile UI developer(s) – it seems to be a wonderful package, and it would be exactly the package I would have developed for this purpose if I still were mainly a programmer. I started out as a programmer, but haven’t done it in a couple decades, so having a tool that handles the UI and database functions easily so that I can work on the business logic is infinitely helpful.

I’m a very new user of Agile UI and the related family of items, but I think I’ve found a bug with the recently released Agile UI 1.6.1. The problem is that when I use the edit button on a standard CRUD object I get an extra popup – “localhost says false,” with and OK and a cancel button in it. If I hit “cancel” then nothing happens (it goes back to the main window). If I hit “OK” then it takes me to the edit modal window as expected.

I get a similar effect if I hit the delete button, too. Except this time the popup says “local host says Are you sure?” with the OK and cancel buttons. If I hit cancel, it goes back to the main window. If I hit “OK”, then the popup goes away and an identical one shows up. The second time, if I hit cancel nothing happens, but if I hit “OK” then it actually does delete the record.

I was sure that this was because of something stupid I did in my application, as I’m just getting started and am by no means an expert. I only recently finished the tutorials, and none of them had this behavior. However, in my new application I copied the bare minimum code from the party planner tutorial admin page – and saw the same behavior. I then went back to the party-planner application, and confirmed that it didn’t show the same behavior, and it was fine.

On a hunch, then, since I’d noticed that there was a recent update to Agile UI, and I’d just installed it for the new application, I went into the party-planner tutorial directory and did a “composer update”. After I did that, and nothing else, the party-planner tutorial showed the same problem – extra popup messages.

The composer update made the following changes:
atk4/core: 1.3.9 => 1.3.10
atk4/dsql: 1.2.5 => 1.2.6
atk4/data: 1.3.7 => 1.4.0
atk4/ui: 1.6.1 => 1.6.2
It also removed symphony/css-selector, instaclick/php-webdriver, behat/mink-selenium2-driver, and behat/mink. Those must have been dependencies of other atk4 items – the only items I require direction in my json file are atk4/ui and atk4/login.

It wouldn’t surprise me at all if I’ve got some kind of configuration issue that’s triggering it. But I’ve got no idea what. I’m using goggle chrome as a browser (same thing happens in Microsoft Edge) on a Windows 10 machine. I’m using Wampserver 3.1.4 for my web and database server.

However, even if it is my code that’s causing the problem, I suspect that the developers would want to know about it/address it so that the package works well in more situations. Here’s all the code it takes to generate the problem:

require ‘vendor/autoload.php’;
$app->add(new \atk4\login\Auth())->setModel(new \atk4\login\Model\User($app->db));
$app->add(‘CRUD’)->setModel(new \atk4\login\Model\User($app->db));

To be completely thorough, I created a new directory, did a “composer require atk4/login” in that directory, put that code into a php file in that directory, and loaded it into the browser. It demonstrates exactly the same behavior, with the same extra popups.

Thanks in advance for any help you can give.


I have the same problem.


If you drop all fresh agiletoolkit files into a new directory without running composer, does it work? (I never ran composer on my install since I don’t have those permissons yet agiletoolkit works for me)


I just tried this – it does “work.” I downloaded a fresh agiletoolkit, into a new directory, and simply tried the admin demo in the main index. I can add a new testclient without a problem. And the functionality of editing or deleting a record works – but I still get the same duplicated “Are you sure” messages when I delete a record, and I get the same “localhost says false” popup when I edit a record in a CRUD.


Hi all. I’m just wondering if this is still an issue?

If yes - please report bugs in https://github.com/atk4/ui/ , most of our contributors are there and would have noticed.


I’ve not seen it recently – it was fixed a while back. Oddly enough, since it was fixed at one point I noticed that it was there in the online demos at http://ui.agiletoolkit.org/demos/index.php. I just checked, and those demos do show the bug right now.