Dependency Issues with UI and Report

I have installed UI via composer. No issues. When I try to install report via composer, I get dependency issues:

php ../mycomposer/composer.phar require atk4/report --ignore-platform-reqs
Using version ^1.0 for atk4/report
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - atk4/report 1.0.1 requires atk4/schema ^2.0 -> satisfiable by atk4/schema[2.0.0] but these conflict with your requirements or minimum-stability.
    - atk4/report 1.0.0 requires atk4/schema ^2.0 -> satisfiable by atk4/schema[2.0.0] but these conflict with your requirements or minimum-stability.
    - Installation request for atk4/report ^1.0 -> satisfiable by atk4/report[1.0.0, 1.0.1].


Installation failed, reverting ./composer.json to its original content.

schema requires dsql 2.0 but ui requires dsql 1.2.6.

Any way to get this fixed?

Hello,

This works for me in the composer.json file:

     "require": {
        "atk4/ui": "dev-develop#1ca8f16 as 1.7.1",
        "atk4/data": "dev-develop#073dfb1 as 1.4.1",
        "atk4/dsql": "dev-develop#7f85985 as 1.2.5",
        "atk4/schema": "dev-develop#e99a481 as 1.1.6",
        "atk4/report": "dev-develop#8ed1b4b" 
}

Support responded to me via email and there was an issue that they corrected on 12/15. The UI 2.0.x was not in the repo.

The dependency issues should be fixed now - some add-ons may need to be updated to use 2.0 versions (in the composer.json file).

I think Chart still has an issue. It hasn’t been updated in the GitHub and the composer.json file it comes with (when looking at the source) wants to use ^1.6.x of UI. So if I try to install using composer, it fails.

Problem 1
- Installation request for atk4/chart ^1.0 -> satisfiable by atk4/chart[1.0.0].
- atk4/chart 1.0.0 requires atk4/ui ^1.6 -> satisfiable by atk4/ui[1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.7.0, 1.7.1] but these conflict with your requirements or minimum-stability.

I had responded back to the support case I had opened about this as well and hadn’t heard back (rightfully so due to the holidays).