Atk4.3 installer problems

Hi,

Just Downloaded the new 4.3 version. Congrats for new veriosn release.

Got a few issues…

  1. Instaler uses Phar but when xChache enabled, Phar does not work, or sometime this is a issue with suhosin.

Fatal Error: Uncaught exception ‘PharException’ with message '__HALT_COMPILER(); must be declared in a phar

  1. Removing phar file requires agiletoolkit-sandbox folder that is not available in default installer. (Should there be two different downloads or I am missing something). Also tried to update via composer… but no luck.

  2. Why heroku included in composer.json ??

Hi Gowrav,

  1. can you give the exacts specs for your host? Linux, which distort, etc. I’ll try to recreate and find the problem.

  2. You can remove PHAR and in your browser open:

    agiletoolkit/admin/public

    You won’t have installer or any extra features without .phar, but you still can use Agile Toolkit 4.3. I recommend disabling suhosin on your local development environment, and .phar is not deployed to your live site anyway, it’s only to help with development.

  3. To answer question about heiroku, it’s for heroku buildpack:
    (https://github.com/CHH/heroku-buildpack-php#configuration)

I’ve updated installer 2 days ago. I’m still curious how to reproduce your problem.

HI,

Still the same problem with phar files. I am able to use composer.phar very well.

Here is my configuration for development pc

http://jsfiddle.net/en7cok0t/embedded/result/

This looks like a bug with xcache that should have been resolved years ago but persists. There is a fix here (sort of): http://xcache.lighttpd.net/ticket/273

if enabling constant cache doesn’t work, you can also use a .htaccess flag to disable xcache in that location. Details here: http://www.rackspace.com/knowledge_center/article/cloud-sites-php-op-code-cache

Can you provide sample .htaccess file that would fix the problem ? I’ll include it in distribution.

Romans,

It can just be

php_flag xcache.cacher 0

…But that will disable xcache completely and it’s only a problem in some cases.

Thanks. That should be fine for development environment.