ATK version and samples : how to?

I plan to develop a complex application with ATK toolki. I install version 1.7.1 and login addon.
Demo from addon crash : it seems version of atk/core is different in sample.
Demo need ConfigTrait.php (core) wich does’nt exist in 1.7.1 !
It is almost the same problem with all the demos… :roll_eyes:

Basic install via composer :

C:\wamp64\www\login>composer require atk4/ui
Using version ^1.7 for atk4/ui
./composer.json has been created
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 5 installs, 0 updates, 0 removals

  • Installing psr/log (1.1.2): Loading from cache
  • Installing atk4/core (1.3.10): Loading from cache
  • Installing atk4/dsql (1.2.6): Loading from cache
  • Installing atk4/data (1.4.1): Loading from cache
  • Installing atk4/ui (1.7.1): Loading from cache
    atk4/dsql suggests installing jdorn/sql-formatter (*)
    Writing lock file
    Generating autoload files

C:\wamp64\www\login>composer require atk4/login
Using version ^1.0 for atk4/login
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 2 installs, 0 updates, 0 removals

  • Installing atk4/schema (1.1.6): Loading from cache
  • Installing atk4/login (1.0.1): Loading from cache
    atk4/schema suggests installing jdorn/sql-formatter (*)
    Writing lock file
    Generating autoload files

What is the way to get a correct configuration for all addons ?

Thanks

Some “getting started” guides are out of date. Please join our Wednesday call and we can help you out.

We’re still on https://gitter.im/atk4/atk4 but are transitioning into other channel soon, stay in touch!